Announcement

Collapse
No announcement yet.

Quake I mdl export problem

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Quake I mdl export problem

    Hi there. I recently managed to set up blender, python and the q1 ex-/import script.
    After editing a model i wanted to extract it, which worked fine. I oipened it in Qme and q2Mdlr to see if those programs could read and display the model correctly, which also worked.
    But when i start quake (no matter which engine), the wean model didn't show up. It was invisible. I then tried to extract it as an .md3, which also didn't work. I get no error messages from neither Quake nor blender nor one of the other programs.

    Also, in blender, when i open the UV editor, i can't see the uv coordinate pivots.

    I didn't edit the origin of the model, so it should still be where it was. Am i missing something?!

    Blender version: 2.78
    Python : 2.713



    Nevermind, i solved it..

    Greetings,
    Tkj
    Last edited by TheKillingJoke; 07-24-2017, 09:18 AM.
    I once was a Ranger like you. But then i took a rocket to the knee.

  • #2
    Glad you solved it. You may want to post the solution as well in case anyone else experiences the same problem someday.
    'Replacement Player Models' Project

    Comment


    • #3
      I second that."Nevermind, I solved it" is almost a heart-breaking statement.

      Comment


      • #4
        It was my own fault, typical marriage of too much coffe and impatience.
        I didn't install the correct python version. I just downloaded it, but didn't deinstall the previously installed. The version numbers in the first post are the right ones. I downloaded them after reading about it in a post from the user Adam.

        About the UV pivots: I'm not used to edit .mdl stuff. Usually i edited Fallout 3, Oblivion and Skyrim meshes, which works a little different. After setting up the whole progs i didn't select the vertexes in the 3d view panel of blender, so nothing was highlighted in the UV panel.

        I'm slowly getting to where i can at least modify existing quake models.

        So for me works :

        Install Blender version: 2.78
        Then install Python : 2.713
        Then download
        taniwhas im/export script

        After that open blender, click
        File -> User preferences -> Import/Export ->
        Install from file -> choose "io_mesh_qfmdl-0.7.2.zip" from its download folder.

        Thread with Adams suggestions : http://quakeone.com/forum/quake-help...n-milkshape-3d

        Also, sorry for my grammar, english is not my native language.

        Edit: I have no intention of breaking any of your hearts, guys :-)
        I once was a Ranger like you. But then i took a rocket to the knee.

        Comment


        • #5
          @sorry...Grammar

          Hah! English is my only language and I absolutely make up grammar as I go. If you ever heard me speak you would probably think that I am an English major or something. I speak very well. Typing though...uh, if I at least get periods right I feel like I've accomplished something. ...and there is no guarantee my periods will appear where they are supposed to. It's hard to determine a complete thought when there are 50 of them or so going on in your head at any given time.

          Comment


          • #6
            Hello again, i ran into another problem and this time a can't manage to solve it myself, neither by trail & error, nor with the help of this or the blender forum or even with an old tutorial from moddb.
            My problem is, that i can't find the correct way to export a model with its animations or i don't use the right method of animating the model.
            I made a Quad barreled shotgun, made 8 shapekeys, put them into the timeline (current Shapekey value set to one, -> click on frame on timeline -> press i -> LocRotScale) and exported the mesh. Doesn't work.

            Added a 1 bone armature, set it to parent for the mesh, added animations by rotating/translating the bone before pressing i on the timeline and choosing LocRotScale, exported the mesh, doesn't work either.

            Then i weightpainted the mesh until everything was blood red, repeated the animation proces for the 8 frames... doesn't work.

            I opened every version in Qme - no animation steps present on the shotgun.
            Does anybody know where i can read about this or does one of you guys 'n women know what i am doing wrong !?


            This is so goddamn embarrassing! This is the second time i posted a problem and found the solution a minute later I didn't knew that i had to set the value slider of the shapekey to 1.
            Somebody donate me some brain please I think i write a little tutorial about animating Quake 1 .mdl files with blender now.
            Last edited by TheKillingJoke; 08-05-2017, 01:10 PM.
            I once was a Ranger like you. But then i took a rocket to the knee.

            Comment


            • #7
              Haha I was going to say make sure you're on the right frame before export
              'Replacement Player Models' Project

              Comment

              Working...
              X