Announcement

Collapse
No announcement yet.

GLSL vs Multitexture shader mode when importing into Quake models created in Blender.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • GLSL vs Multitexture shader mode when importing into Quake models created in Blender.

    Hi QuakeOne!

    The next obstacle with my quake mod:

    I made two models: a sword and a spear. The sword was exported as a .mdl and imported into Quake successfully (thanks everyone in this helpful post).

    I attempted to do the same with the spear. However, for some unknown Blender reason, it won't show up in the viewport even if it's set to display textured objects unless I change the shader settings to GLSL. Problem is, Quake seems not to accept textures like that and the spear will appear texture-less in-game (that is, if exported with GLSL mode). Both models were texture-painted.

    I've posted a question in Blender.StackExchange to get better insight on what are the differences between these two settings and what could be wrong in the spear .blend file so that it won't render the texture in multitexture shader mode, which is the way Quake seems to like its 3D models.

    I believe this probably can be changed in Quake itself but I'd like to keep all of my models using the same shader options for the sake of simplicity and unity.

    Best,
    wizardmachine

  • #2
    I unpacked the texture, saved a new image externally and linked the source path of the image back again to the texture slot in the material assigned to the object. Issue seems gone!

    Comment

    Working...
    X