Announcement

Collapse
No announcement yet.

Problem with QBSP compiling. Possibly pathing issue and I can't seem to find a fix.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem with QBSP compiling. Possibly pathing issue and I can't seem to find a fix.

    Hi there! Long time Doom player/mapper* looking to branch out, especially after learning about Trenchbroom and being completely blown away by it. I'm running into a bit of an issue with the QBSP compiler and since programs like Doom Builder are available that seems to have everything already streamlined for compiling, I've never had to deal with any external issues like this when trying to construct and playable level.

    Here is the rundown after running Necros' GUI:


    Code:
    ---- qbsp / TyrUtils v0.15 ----
    Input file: test2.map
    Output file: test2.bsp
    
    ---- LoadMapFile ----
    *** WARNING 06: No info_player_deathmatch entities in level
    36 faces
    6 brushes
    2 entities
    2 unique texnames
    15 texinfo
    
    Opened WAD: C:/Users/Matt/Desktop/Games/Quake/Q.wad
    Processing hull 0...
    ---- Brush_LoadEntity ----
    6 brushes
    ---- CSGFaces ----
    36 brushfaces
    36 csgfaces
    36 mergedfaces
    ---- SolidBSP ----
    24 split nodes
    6 solid leafs
    19 empty leafs
    0 water leafs
    44 leaffaces
    44 nodefaces
    ---- Portalize ----
    19 vis leafs
    19 vis clusters
    40 vis portals
    ---- FillOutside ----
    18 outleafs
    ---- MergeAll ----
    6 mergefaces
    ---- SolidBSP ----
    6 split nodes
    6 solid leafs
    1 empty leafs
    0 water leafs
    6 leaffaces
    6 nodefaces
    ---- Portalize ----
    1 vis leafs
    1 vis clusters
    0 vis portals
    ---- Tjunc ----
    12 world edges
    24 edge points
    0 edges added by tjunctions
    0 faces added by tjunctions
    ---- MakeFaceEdges ----
    ---- GrowRegions ----
    Processing hull 1...
    *** WARNING 19: No entities in empty space -- no filling performed (hull 1)
    Processing hull 2...
    *** WARNING 19: No entities in empty space -- no filling performed (hull 2)
    ---- WriteBSPFile ----
    35 planes 700
    8 vertexes 96
    6 nodes 144
    15 texinfo 600
    6 faces 120
    112 clipnodes 896
    2 leafs 56
    6 marksurfaces 12
    24 surfedges 96
    13 edges 52
    2 textures 27740
    lightdata 0
    visdata 0
    entdata 149
    
    0.025 seconds elapsed
    Peak memory usage: 275672 (269.2k)
    At the end of this line, it prompts two identical lines that read "The system cannot find the file specified". I've checked the directory lines and I don't see any spaces or anything that the CLI would have any problem with, so I was wondering if anybody else has had this particular issue.

  • TheKillingJoke
    replied
    Which file exactly can't be found? The .bsp or the .prt or the .pts file?
    Tyrutils doesn't perfom the filling because of 2 entities in empty space. Hence i think the file it tries to process is not existent. Can that be the case? Maybe you try to find and remove the entities in the empty space and put them into an interior, so the filling can be performed. That could solve the problem. Hard to say.

    Leave a comment:

Working...
X