Announcement

Collapse
No announcement yet.

GTKRadiant not loading textures?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • GTKRadiant not loading textures?

    OK, so i would like to start doing some Quake mapping, so I downloaded GTKRadiant and set up the paths to my Quake directory. However when I opened up the texture browser the only texture there was the SHADER NOT FOUND texture, and when I looked in the console it said "Texture load failed: "textures/" ". Anybody know how to fix this?

    Also I'm sorry if I got this in the wrong forum, or if this question has been asked before.
    Last edited by arrrgh; 09-14-2009, 02:39 AM.

  • #2
    i only know how to set up QuArK because peg learned me it

    you may want to try fu..... oh, you already did

    Comment


    • #3
      Solved. Apparently you need a wad file for textures which can be downloaded here(get quakewad and rename the quake101.wad to quake1.wad) to put in your id1 folder. Hope this helps someone!
      Last edited by arrrgh; 09-14-2009, 02:38 AM.

      Comment


      • #4
        Sorry for reopening such an old thread, but it is the very same issue, so I find it is better to continue the questioning here, rather than to open a new thread.

        Originally posted by arrrgh View Post
        Solved. Apparently you need a wad file for textures which can be downloaded here(get quakewad and rename the quake101.wad to quake1.wad) to put in your id1 folder. Hope this helps someone!
        I have done the same thing, though I used q.zip, which in the .diz states that 'This is a texture wad for Quake, meant as a replacement for Quake101, Hipnotic, Rogue and CTF4 wad files.' I do however have issues with GTK. I finally caved in getting GTK to work as intended, because every time I saved the file, it reopened without any textures showing up, as explained in this Imgur album, stating 'WARNING: could not find "[texturename]" in any listed wad files, searching all wad files instead!'; however, as explained in the linked album, the textures are in fact there, but displayed both as notex and as existing.

        Were it not for the fact that bsp fails to work with NetRadiant, I would have switched. GTK is my thing, though; it's been years and years since I used it (last time for Q3A), and I have now run into a complete halt in trying to get it to work. Any and all help would be much appreciated. To make matters worse, neither in GTK nor in NetRadiant can I get the correct texture for caulk (it instead shows as notex), which is quite annoying; it is as though it isn't there at all.

        A postscriptum: I asked for help on this at Quaddicted, but that forum seems to be dead.
        Last edited by Canned Man; 03-01-2019, 10:23 AM. Reason: This forum apparently doesnít support UTF-8.

        Comment


        • #5
          I'll bump this with some extra info:

          After running Bengt Jardrup's compiler (the regular one didnít work), I found that there are errors in the map with regards to worldspawn entity not specifying which wads to use. Could it be that this is the cause? I have tried to open the entities list to edit worldspawn, but I am not allowed to add any keys to it (meaning I amongst other things cannot choose which track to play, what the name of the map should be, et c.). Could anyone explain to me how I should go about editing the worldspawn entity to include the necessary information for the map to work?

          Comment


          • #6
            This may not be the best way, but it's probably the easiest... Open the .map file in a text editor and add the info at the top. Look at a stock .map file for how to add it, if you don't already know.

            Comment


            • #7
              I retried doing this today, basing the top of the file with that of DM1.MAP. My map-file now reads as such:
              Code:
              {
              "sounds" "2"
              "worldtype" "0"
              "wad" "quake1.wad"
              "classname" "worldspawn"
              "message" "Testkart"
              After doing this, I can reload the map in GTK with textures, so thatís an improvement.

              The name of the wad file in my id1 folder is, as noted above, quake1.wad. Still, when I run txqbsp (BJís) on it, I get the following readout:

              D:\Spill\bj\TXQBSP>txqbsp d:\arkiv\kartlaging\quake\test.map d:\spill\quake\id1\maps\test.bsp


              TxQBSP 1.13 -- Modified by Bengt Jardrup

              Inputfile: d:\arkiv\kartlaging\quake\test.map
              Outputfile: d:\spill\quake\id1\maps\test.bsp
              ------ LoadMapFile ------
              WARNING: Multiple info_player_start entities on line 71
              Title: "Testkart"
              36 faces
              6 brushes
              4 entities
              4 miptex
              8 texinfo
              WARNING: No valid wadfiles in worldmodel

              Building hulls sequentially...
              [⋮]
              ------ FinishBSPFile ------
              WriteBSPFile: d:\spill\quake\id1\maps\test.bsp
              17 planes 340
              30 vertexes 360
              6 nodes 144
              8 texinfo 320
              24 faces 480
              12 clipnodes 96
              2 leafs 56
              24 marksurfaces 48
              104 surfedges 416
              53 edges 212
              0 textures 0
              lightdata 0
              visdata 0
              entdata 301

              2 warnings
              Ö
              Ö
              Now what? I am at the end of my knowledge, and really have no knowledge of how to pursue this. I should mention that my background is mainly from Q3 map editing, not Q1 (I used to dabble a bit in Worldcraft for Q1, and a tiny bit in Q3). Might it be that my not finding a proper caulk texture for Q1 is because it is not supposed to be there (not parsed by the engine at all?)?

              Another issue I am having, is that I have no access to the bsp commands in the bsp menu in GTK. I have installed it multiple times, and it doesn't change anything. There are multiple BSP options in NetRadiant, but I do prefer running GTK, as that is the software I am accustomed to.
              Last edited by Canned Man; 03-04-2019, 10:52 AM. Reason: Corrected formatting

              Comment


              • #8
                Finally solved, thanks to a guest at Quaddicted. The cause of the problem was my assuming that QBSP assumed that the wad file had id1 as its base path. Simply entering the full path solved the problem!

                Comment


                • #9
                  Good. I was just about to say that it seemed like BSP didn't know where the wad file was located. Glad you got it working.

                  Comment

                  Working...
                  X