Announcement

Collapse
No announcement yet.

Darkplaces 3D texture command help

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Darkplaces 3D texture command help

    Hi guys!

    So a few years ago I was experimenting with Darkplaces and I stumbled upon a console command that made the flat textures look 3D (in that as you walked around the texture, it would change shape and look all 3d and stuff, like the rocks looked like they were sticking out of the ground). I later learned that this effect is called parallax occlusion and it does work with the HD textures I'm using because not only they come with normal/bump maps included but I also got it to work with these same textures back in the day.

    So here's my problem, My old PC couldn't handle this hectic effect so I had to disable it, and then I forgot about it for years.
    Today I have a new powerful PC (GTX 1080, Ryzen 5 2600X, 32GB RAM) and I only now just recently remembered this cool effect that I want to enable BUT I cannot remember what the command is and I simply cannot find it in the list of Darkplaces commands. I first thought it was "r_glsl_offsetmapping" and "r_glsl_offsetmapping_reliefmapping" but no. When I enable it, it really does nothing other than mess up the character and gun models a bit. Can anyone help?

    Could this be an issue with newer versions of darkplaces? The type of PC I'm using? (I doubt it).

    Thanks

  • #2
    Hello MXDash,

    First of all, by reading your post and the issues that you have, you seem to be using Rygels texture pack. That was released around 2007.
    Unfortunately this pack has issues and bugs. One of them leads to your described behaviour: messed up gun models.
    The reason for this particular issue is because Rygel had alpha channels in his normal textures.

    My advice is to start with a new Quake folder and use the updated/new textures from the QRP team. Those guys are the ones behind Rygels texture set anyhow.
    What you should use is a newer DarkPlaces build as well. It has lots of bugfixes and supports new features/maps etc.
    Please use this one: Download

    Create a folder called "Quake". Inside this folder create a subfolder called "id1". That is it.
    Now extract the DarkPlaces build into the Quake folder directly.
    And copy your pak0.pak and pak1.pak into the id1 folder.
    Now you can already play Quake.

    Next you download the recent QRP world textures AND the normal texture addon, as you want to have the offsetmapping visuals: Download
    While you are there you should also download QRPs item textures.
    Extract the 7zip files so that you have the .pk3 files. Put the .pk3īs into your id1 folder.
    Now you have all the newest/updated game textures in high resolution and ready to use offsetmapping.

    If you want to also have all the game models (like weapons, monsters, powerups, etc.) in a new shape there is also a download link for them available,
    but lets first concentrate on your offsetmapping issue.

    Now start your Quake via the darkplaces.exe file.
    Setup your resolution and key bindings, etc.
    Once everything is set you can go into console and enable the offsetmapping features.
    There is unfortunately no ingame-option menu point for this.
    To enable it type: r_glsl_offsetmapping 1
    To disable it type: r_glsl_offsetmapping 0

    You should see the difference directly.

    Instead of showing screenshots I link an old video clip I once made to see the effect.
    The clip was not intended to show offsetmapping but due to the fact that it has many passages where the player stays near walls you can see it quite good:


    I hope you could solve your issue.
    If you have further questions, fell free to ask.

    Best wishes,
    Seven

    Comment

    Working...
    X