Announcement

Collapse
No announcement yet.

Occassional Quake Lockups

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Occassional Quake Lockups

    Hey there fellow Quakers. I don't often come to the forums for discussion, but I'm hoping I can find someone that will be able to shed some light on this not so great situation.

    I use the ProQuake Launcher to start Quake. During gameplay, I'll get what initially seemed like very tiny lag spikes. The more I played, the more frequent the spike. I have come to the conclusion that it's definitely not a lag spike. The game will completely lock up for one or two seconds. It happens as often as every 5sec, every 15sec, or sometimes when I'm lucky it's even 30-60sec.

    I have tried to use other Quake engines, but no luck. The things I have not tried are reinstalling Quake and, my old favorite, reformatting my hard drive completely.

    If anyone has any leads as to how I can resolve this issue, I would greatly appreciate it. Thank you

  • #2
    Forgot to ask one important thing. Do these spikes and lockups only happy on multiplayer or do they happen in single player as well? If its only in multiplayer then ignore the video section below. If it is in multiplayer only, check your PQ_MAXFPS make sure its set to like 30 or lower. There is a setting for it in QRACK under the video menu too. Also test your connection to whatever server you are playing on and having this issue on.


    Are you getting the same thing with these 3 Engines?
    GLQUAKE
    QRACK
    GLPRO

    If not then it may be some type of setting or video setting related setting within the Engine you are using.

    If so then it may be a video setting or driver compatibility issue with your video card/drivers.

    Try Grabbing the latest drivers for it. If you are using a dell then try getting the video card manufactuers drivers instead of the dell packaged ones.

    If you already have that or that doesnt work, try finding an Older driver from like 2 years ago for your video card. Many places out there catologue old drivers. Try installing that.

    Make sure you uninstall your video card and reboot then point to the new or old drivers.


    Also is quake on your main Hard drive? Are you having any other issues similiar to this in other games or programs that could point to hard drive reading issues?

    Also make sure you try the basics: clean system/defrag/updates, etc...

    Let us know and we can try and troubleshoot it more after you return some more info for us.



    good luck.

    Comment


    • #3
      First of all, thank you for the speedy reply.

      I don't remember what other engines I tested when seeing if they had similar problems. I will definitely make sure that I test the engines you listed here.

      I don't believe it to be a driver related issue. The problem has been happening for a while now, but I hadn't done anything drastic to my computer or anything that'd create any issues when I first started noticing it.

      To answer the last of your questions, yes, Quake is on my main hard drive. C:\Games\Quake1. I also play Diablo 2:LoD and World of Warcraft:Burning Crusade, both of which I run at full speed with no discrepancies.

      I have not defragged in a while, so that might be a step in the right direction. When I get home from work (it's nice to be able to browse my gaming sites from work) I'll do all my troubleshooting.

      -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-

      EDIT: I haven't tested single player for the spikes. I vaguely remember the PQ_MAXFPS command, though, which I wouldn't remember had I not seen it recently. I'll have to check to see what my current setting is. As far as the servers go, it's on all of them. Shmack, Speaknow, Rage. Those are the primary servers I play on.

      Forgot to ask one important thing. Do these spikes and lockups only happy on multiplayer or do they happen in single player as well? If its only in multiplayer then ignore the video section below. If it is in multiplayer only, check your PQ_MAXFPS make sure its set to like 30 or lower. There is a setting for it in QRACK under the video menu too. Also test your connection to whatever server you are playing on and having this issue on.
      Last edited by Deigo; 07-31-2008, 01:05 PM.

      Comment


      • #4
        It's really hard to test this issue with a 200 ping right now.

        I joined a multiplayer game and noticed the problem nearly immediately. I then switched to a single player game and beat the first few levels with no discrepancies. This being the case, I followed your advice and checked my pq_maxfps. My max FPS was set to 72. Upon changing it to 30, I went to an empty multiplayer game. I didn't notice any mouse lock ups, so thank you very much, if it's fixed that is. Like I said, it's hard to test with a 200 ping.

        Regardless... thank you for your support and I appreciate the time you put into solving my problem. This is what makes this Quake community so strong.

        Comment


        • #5
          its also trhe fact that we can spawn with no forced wait period that makes us strong

          Comment


          • #6
            Occasional Quake Lockups

            Tested with normal ping last night - still an issue. I don't have much time when I sit down and play, so it may be a slow process. My next step is to test the three different clients you mentioned.

            Comment


            • #7
              Something or someone is hogging all your bandwidth. Are you downloading torrents or uploading of any nature?

              If your ping got better when you dropped from 72fps to 30fps, then its not resolved issue's yet.

              Are you on a LAN with other computers? If not, and not torrenting anything , you should go get a copy of SpyBot S&D and maybe AdAware FREE Edition. Both can be located a www.download.com

              Your shitty ping could also indicate problems with your ISP.

              in command prompt
              tracert 69.64.35.230 (this is shmack)

              If you have 200ms or * showing up within the first few hops, then its your comps problem or routers problem, something local to you that you can fix.

              If you have quick ms times in the first half of your tracert, then somewhere it goes to shit after your initial hops, then it isnt your isp,its most likely your routing to the server.Get on MSN newb
              Want to get into playing Quake again? Click here for the Multiplayer-Startup kit! laissez bon temps rouler!

              Comment


              • #8
                I wish there were a standardized way to at least figure out what is going on in situations like these.

                I hope that trying different clients solves the problem, but I don't believe it will.

                Things I've noticed that can cause performance loss:

                1. Close browser. Flash advertising is extremely CPU intensive and I've suffered FPS loss and other things merely by keeping the Quakeone homepage open because some intensive Flash animation in an ad is running.

                2. Rude stuff in the background doing updates, phoning home, etc. This includes antivirus sometimes and often other apps.
                Quakeone.com - Being exactly one-half good and one-half evil has advantages. When a portal opens to the antimatter universe, my opposite is just me with a goatee.

                So while you guys all have to fight your anti-matter counterparts, me and my evil twin will be drinking a beer laughing at you guys ...

                Comment


                • #9
                  Originally posted by Mindf!3ldzX View Post
                  Something or someone is hogging all your bandwidth. Are you downloading torrents or uploading of any nature?

                  If your ping got better when you dropped from 72fps to 30fps, then its not resolved issue's yet.

                  Are you on a LAN with other computers? If not, and not torrenting anything , you should go get a copy of SpyBot S&D and maybe AdAware FREE Edition. Both can be located a www.download.com

                  Your shitty ping could also indicate problems with your ISP.

                  in command prompt
                  tracert 69.64.35.230 (this is shmack)

                  If you have 200ms or * showing up within the first few hops, then its your comps problem or routers problem, something local to you that you can fix.

                  If you have quick ms times in the first half of your tracert, then somewhere it goes to shit after your initial hops, then it isnt your isp,its most likely your routing to the server.Get on MSN newb
                  It's definitely not a bandwidth issue. The high ping last night was a random disturbance from the ISP. Even with the high latency, I noticed the lock ups when playing a few games at Shmack. When my latency lowered to normal, I played a few CA games and noticed the lock ups more frequently.

                  Note: The lock ups ARE NOT tied to latency issues in any way.

                  -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-

                  EDIT: I'm at work right now. No MSN access


                  I wish there were a standardized way to at least figure out what is going on in situations like these.

                  I hope that trying different clients solves the problem, but I don't believe it will.

                  Things I've noticed that can cause performance loss:

                  1. Close browser. Flash advertising is extremely CPU intensive and I've suffered FPS loss and other things merely by keeping the Quakeone homepage open because some intensive Flash animation in an ad is running.

                  2. Rude stuff in the background doing updates, phoning home, etc. This includes antivirus sometimes and often other apps.
                  I have done things of this nature to help minimize the lock up spikes. I tinkered with my MSCONFIG to make sure ALL things were turned off. I then rebooted my computer and opened only Quake. To no avail, the lock up spikes returned shortly.

                  Comment


                  • #10
                    Is this multiplayer only or does it also happen in single player?

                    I ask because I saw something similar before with a wireless NIC. Can't remember the make or model, but it would cause Q1 to randomly pause for about a second at a time. Disabling it in Device Manager was the only solution I found.
                    IT LIVES! http://directq.blogspot.com/

                    Comment

                    Working...
                    X