Site Navigation
QuakeOne News
» Latest News
» News Archives
» QuakeOne Movies

QuakeOne Help
» File Downloads
» Quake Help
» Quake Servers

QuakeOne Community
» Forums
» Poll Booth
» Memberlist
» Member Map

» Buy Quake

Visit QuakeOne.com On Facebook!Visit QuakeOne
on Facebook

Log in
User Name:

Password:

Not a member yet?
Register Now!
Online Users: 134
10 members and 124 guests
Cobalt, concept, Grim Warlock, Hydro...!, Johnny Law, Krymzon 45, Legend, Mom, Moon[Drunk], Noodle-Shop
Most users ever online was 647, 03-12-2011 at 05:53 AM.
Go Back Home > Forums > Quake Help > General Help > darkplaces gives errors with latest nvidia drivers 304.79 Search Forums

Closed Thread
LinkBack Thread Tools
Unread 07-26-2012, 07:43 AM   #1 (permalink)
Chthon
talisa's Avatar
USER INFO »
Posts: 2,808
+/-  Reputation: talisa will become famous soon enough
Join Date: Oct 2011
Currently: Offline
darkplaces gives errors with latest nvidia drivers 304.79

hey all,

just earlier i installed the latest nvidia 304.79 drivers, and now at startup darkplaces suddenly gives a bunch of errors.
i dont notice any difference at all when playing, no messed up stuff or missing features or such as far as i can tell but still im curious what these errrors are, cuz i never got them before, only now with the latest nvidia drivers 304.79

made darkplaces log everything to a file, file is attached. the errors are near the bottom of the file

can somebody tell me what these errors mean? never got them before and im curious what they mean? especially cuz i do not notice any difference at all when playing darkplaces


EDIT: btw forgot to add... im using darkplaces build 20110702
Attached Files
File Type: txt log.txt (18.8 KB, 11 views)

Last edited by talisa; 07-26-2012 at 08:29 AM..
Unread 07-26-2012, 11:27 AM   #2 (permalink)
FTEQW Author
USER INFO »
Posts: 696
+/-  Reputation: Spike is on a distinguished road
Join Date: Jul 2010
Currently: Offline
short version: the driver is unable to process some material that the game is trying to use.
DP will try to fall back to something else instead, you'll probably loose offsetmapping or something.
Something will be drawn still, but not what you've configured the engine to try to draw.

a quick google shows the function its reporting as specific to nvidia's cuda stuff, not opengl/glsl. I think it unlikely that DP would ever use a non-glsl function for glsl and if it did the previous version should error as would any intel or ati/amd drivers.
so looks like a driver bug to me. a very dodgy looking one.

its also possible that you have a custom 'glsl/default.glsl' file in some pk3, but I think it unlikely that such a file would refer to cuda symbols. never say never though, eh?
Unread 07-26-2012, 12:43 PM   #3 (permalink)
Chthon
talisa's Avatar
USER INFO »
Posts: 2,808
+/-  Reputation: talisa will become famous soon enough
Join Date: Oct 2011
Currently: Offline
no i dont. beside, i never got those errrors with older drivers.

anyways, i downgraded to the previous driver version, which instantly solved it.
already expected it would be a driver bug and not a darkplaces bug, so downgraded back to previous driver version

thanx anyway for the help

Last edited by talisa; 07-26-2012 at 12:55 PM..
Closed Thread

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 12:44 AM.


eXTReMe Tracker