Site Navigation
QuakeOne News
» Latest News
» News Archives
» QuakeOne Movies

QuakeOne Help
» File Downloads
» Quake Help
» Quake Servers

QuakeOne Community
» Forums
» Chat *new*
» Poll Booth
» Memberlist
» Member Map

Site Info
» Community Rules
» Moderator List

» Buy Quake

Visit QuakeOne.com On Facebook!Visit QuakeOne
on Facebook

Log in
User Name:

Password:

Not a member yet?
Register Now!
Online Users: 379
6 members and 373 guests
303, DeathMaster, NightFright, SpecialBomb, vibok
Most users ever online was 2,542, 06-04-2016 at 12:58 AM.
Go Back Home > Forums > Quake Help > Multiplayer > Local multiplayer not working in Quakespasm (Linux) Search Forums

Reply
LinkBack Thread Tools
Unread 04-29-2017, 09:48 AM   #1 (permalink)
Ogre Fodder
USER INFO »
Posts: 6
+/-  Reputation: SelfDestruct is on a distinguished road
Join Date: Apr 2017
Currently: Offline
Local multiplayer not working in Quakespasm (Linux)

For a while now, I've been trying to get Quakespasm multiplayer up and running between two Linux boxes, but it hasn't been working. If I try to host a non-dedicated server on either machine, they won't connect. I tried hosting a dedicated server on one machine, and that didn't work either. Both clients claim to have the IP address 127.0.1.1, if that helps.

Any info is appreciated.
Reply With Quote
Unread 04-29-2017, 11:25 AM   #2 (permalink)
FTEQW Author
USER INFO »
Posts: 1,115
+/-  Reputation: Spike has a spectacular aura aboutSpike has a spectacular aura about
Join Date: Jul 2010
Currently: Offline
127.0.1.1 ? o.O
that's not a real address, at least not one that can route anywhere. and its not the normal one either so I'm going to assume a typo. either way its not a usable IP address.

127.*.*.* is reserved for 'localhost', don't try to use that to connect to another machine, it won't even reach your network device.
/sbin/ifconfig will hopefully list some other IP addresses that might work a bit better. 192.168.*.* or 10.*.*.* or something, those are the private LAN addresses. other addresses might be subject to hairpin or nat issues, so its generally best to stick to the private ones, if they're on the same lan anyway.

if you've got a (software) firewall or any kind of nat between you, then yeah, good luck with that - either disable it or use my quakespasm fork (aka QSS) that rewrites much of the networking so that you only need a single port open ( http://triptohell.info/moodles/qss/q...m-spike-r7.zip ). Also supports ipv6, for even more addresses that might not work!

You might need to use -ip 0.0.0.0 with the older clients so that they actually accept packets to interfaces other than the single one it auto-detects, though that may be just a windows thing. it may still be needed if you have weird routes, but that's usually not a problem because it confuses everything else too.
__________________
Some Game Thing
Reply With Quote
Unread 04-29-2017, 12:23 PM   #3 (permalink)
Ogre Fodder
USER INFO »
Posts: 6
+/-  Reputation: SelfDestruct is on a distinguished road
Join Date: Apr 2017
Currently: Offline
That totally worked, thanks!
Do you know of a way to get the clients to show the machine's actual IP addresses? Or should I just have the IP on hand?
Reply With Quote
Unread 04-29-2017, 02:07 PM   #4 (permalink)
FTEQW Author
USER INFO »
Posts: 1,115
+/-  Reputation: Spike has a spectacular aura aboutSpike has a spectacular aura about
Join Date: Jul 2010
Currently: Offline
getting the local machine's IP address is system specific with no real standard, which means engines tend to only support the microsoft way, and even then they only report the first.
fteqw does show all of them... including ipv6, link local addresses, qw ports, nq ports, for each network interface you have...

note that most quake engines have some way to scan the local network for games. if its a lan, can you not just use that?...
yeah, NOW I remember that feature.

most lans are 192.168.some_constant_value.some_per_machine_value
so quite often you only need to memorise a single number per machine, usually within 5 of the other machine's number (depends how big your lan is...).
the alternative is to write some line in your autoexec.cfg like the following
alias go "connect 192.168.1.64"
so it depends whether you think you're more likely to remember '64' or 'go'... but yeah, 'go' is also less typing.
__________________
Some Game Thing
Reply With Quote
Reply

Bookmarks

Tags
help with multiplayer, linux, local multiplayer, multiplayer, quakespasm


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 10:42 AM.


eXTReMe Tracker