Site Navigation
QuakeOne News
» Latest News
» News Archives
» QuakeOne Movies

QuakeOne Help
» File Downloads
» Quake Help
» Quake Servers

QuakeOne Community
» Forums
» Chat *new*
» Poll Booth
» Memberlist
» Member Map

Site Info
» Community Rules
» Moderator List

» Buy Quake

Visit QuakeOne.com On Facebook!Visit QuakeOne
on Facebook

Log in
User Name:

Password:

Not a member yet?
Register Now!
Online Users: 228
5 members and 223 guests
303, DeadTenor, Solecord, tech4802
Most users ever online was 2,542, 06-04-2016 at 12:58 AM.
Go Back Home > Forums > Quake Help > Servers and Coding > Set up WC3.3 and quakeadapter - maps compile - map in game has no textures! Search Forums

Closed Thread
LinkBack Thread Tools
Unread 08-09-2006, 04:11 AM   #1 (permalink)
Gib Collector
USER INFO »
Posts: 3
+/-  Reputation: biffsnot is on a distinguished road
Join Date: Aug 2006
Currently: Offline
Set up WC3.3 and quakeadapter - maps compile - map in game has no textures!

I hope someone can help me. I installed WorldCraft 3.3 to c:\program files\worldcraft, installed the QuakeAdapter properly AND set up WC to all the dirs! It compiles fine and runs the darkspaces engine with my map NP at all! But, while compiling the only bad message is "WARNING: No valid wadfiles in worldmodel" and the map has no textures.

As I said its all set up compiles and runs, WADs are in the wads dir, but file->run compiles and then I get no textures. My darkspaces directory is on the e: drive tho so maybe thats a prob? Please help someone lol

KN
Unread 08-09-2006, 04:20 AM   #2 (permalink)
Chthon
Baker's Avatar
USER INFO »
Posts: 9,975
+/-  Reputation: Baker has a spectacular aura aboutBaker has a spectacular aura aboutBaker has a spectacular aura about
Join Date: Nov 2005
Currently: Offline
Typically, if I'm correct, it means the textures were not found by the map compiler.

Make sure the WAD file in question existing in HLWAD format in C:\program files\Worldcraft\textures

Was the map ...

#1 developed from scratch using WC 3.3 or

#2 did you pull in a map created in another editor?

If #1 ....

Do the textures show up while using Worldcraft 3.3?

If #2 ....

Make sure that there is a corresponding WAD converted to HLWAD format.

If you need more help, keep posting and we'll get this figured out. This problem occurred for me once and it was a simple oversight I made.
__________________
Quakeone.com - Being exactly one-half good and one-half evil has advantages. When a portal opens to the antimatter universe, my opposite is just me with a goatee.

So while you guys all have to fight your anti-matter counterparts, me and my evil twin will be drinking a beer laughing at you guys ...
Unread 08-09-2006, 04:31 AM   #3 (permalink)
Chthon
Spirit's Avatar
USER INFO »
Posts: 1,074
+/-  Reputation: Spirit is on a distinguished road
Join Date: Apr 2006
Currently: Offline
It means that you haven't specified wads to use.
Unread 08-09-2006, 02:19 PM   #4 (permalink)
Gib Collector
USER INFO »
Posts: 3
+/-  Reputation: biffsnot is on a distinguished road
Join Date: Aug 2006
Currently: Offline
Originally Posted by Baker
Typically, if I'm correct, it means the textures were not found by the map compiler.

Make sure the WAD file in question existing in HLWAD format in C:\program files\Worldcraft\textures

Was the map ...

#1 developed from scratch using WC 3.3 or

#2 did you pull in a map created in another editor?

If #1 ....

Do the textures show up while using Worldcraft 3.3?

If #2 ....

Make sure that there is a corresponding WAD converted to HLWAD format.

If you need more help, keep posting and we'll get this figured out. This problem occurred for me once and it was a simple oversight I made.

K thanks for the reply, sorry that I didnt reply sooner it was late night when I posted and I went to bed.

It is a fresh install of WC3.3 and I right away installed the QuakeAdapter. So the Wads are HLWAD converted already, the installer took care of that I guess.

This is a new map from scratch basically a large hollow box with a player start and a light just to test lol.

The textures do show in WC3.3 and I have corectly applied them to the floor walls and ceiling in the room. And the settings apear to be right, the tools are all in c:\program files\worldcraft\quaketools the game is in e:\games\darkspaces\ and the maps go to e:\games\darkspaces\id1\maps\



Any other ideas?

oh and here is a bit of message from the compile window -

------ FinishBSPFile ------
WriteBSPFile: E:\games\darkplacesengine20060725\id1\maps\test1.b sp
34 planes 680
130 vertexes 1560
12 nodes 288
3 texinfo 120
110 faces 2200
48 clipnodes 384
7 leafs 196
150 marksurfaces 300
472 surfedges 1888
237 edges 948
0 textures 0
lightdata 0
visdata 0
entdata 255


KN

Last edited by biffsnot; 08-09-2006 at 02:47 PM..
Unread 08-09-2006, 03:37 PM   #5 (permalink)
Chthon
Spirit's Avatar
USER INFO »
Posts: 1,074
+/-  Reputation: Spirit is on a distinguished road
Join Date: Apr 2006
Currently: Offline
You have to specify the wadfile(s) to use in worldspawn, eg
"wad" "quake.wad"

This might help you: http://www.gamers.org/dEngine/quake/QDP/qmapspec.html
Unread 08-09-2006, 06:07 PM   #6 (permalink)
Chthon
Baker's Avatar
USER INFO »
Posts: 9,975
+/-  Reputation: Baker has a spectacular aura aboutBaker has a spectacular aura aboutBaker has a spectacular aura about
Join Date: Nov 2005
Currently: Offline
biffsnot, can you post the entire compile log from the "Process Window"?

Highlight all of the text in the WC3.3 Process Window and right click and then click copy, and then do a CTRL-V in a reply box.

** Executing...
** Command: Change Directory
** Parameters: c:\quake


** Executing...
** Command: Copy File
** Parameters: "c:\program files\worldcraft\maps\test1.map" "c:\quake\id1\maps\test1.map"


** Executing...
** Command: c:\program files\worldcraft\quaketools\nomapversion.exe
** Parameters: "c:\quake\id1\maps\test1"


** Executing...
** Command: c:\program files\worldcraft\quaketools\txqbsp.exe
** Parameters: "c:\quake\id1\maps\test1"

TxQBSP 1.12 -- Modified by Bengt Jardrup

Inputfile: c:\quake\id1\maps\test1.map
Outputfile: c:\quake\id1\maps\test1.bsp
------ LoadMapFile ------
42 faces
7 brushes
2 entities
1 miptex
3 texinfo

Building hulls sequentially...
Processing hull 0...
------ Brush_LoadEntity ------
----+----+
7 brushes read
------ CSGFaces ------
----+----+
42 brushfaces
30 csgfaces
18 mergedfaces
------ SolidBSP ------
62 split nodes
19 solid leafs
44 empty leafs
0 water leafs
307 leaffaces
307 nodefaces
------ FillOutside ------
38 outleafs
------ MergeAll ------
12 mergefaces
------ SolidBSP ------
----+----+
12 split nodes
7 solid leafs
6 empty leafs
0 water leafs
150 leaffaces
110 nodefaces
------ Portalize ------
6 vis leafs
12 vis portals
------ Tjunc ------
68 world edges
304 edge points
32 edges added by tjunctions
0 faces added by tjunctions
------ MakeFaceEdges ------
----+----+
------ GrowRegions ------
Processing hull 1...
----+----+
----+----+
Processing hull 2...
----+----+
----+----+

------ FinishBSPFile ------
WriteBSPFile: c:\quake\id1\maps\test1.bsp
34 planes 680
130 vertexes 1560
12 nodes 288
3 texinfo 120
110 faces 2200
48 clipnodes 384
7 leafs 196
150 marksurfaces 300
472 surfedges 1888
237 edges 948
1 textures 21808
lightdata 0
visdata 0
entdata 255

Elapsed time : 0:03

Peak memory used : 0.2 MB

** Executing...
** Command: c:\program files\worldcraft\quaketools\vis.exe
** Parameters: "c:\quake\id1\maps\test1"

---- Vis 2.31 ---- Modified by Bengt Jardrup

File: c:\quake\id1\maps\test1.bsp
6 portalleafs
12 numportals
State file out of date, will be overwritten
testlevel = 4

Base: 0.0, Elapsed: 0:00
Base: 100.0, Elapsed: 0:00

Full: 0.0, Elapsed: 0:00
Full: 100.0, Elapsed: 0:00

average leafs visible: 6
max leafs visible: 6 near (-128 224 -256), 1/6
c_chains: 78
visdatasize: 6 compressed from 6

Elapsed time : 0:00

** Executing...
** Command: c:\program files\worldcraft\quaketools\light.exe
** Parameters: "c:\quake\id1\maps\test1"

----- Light 1.43 ---- Modified by Bengt Jardrup

File: c:\quake\id1\maps\test1.bsp
2 entities read, 0 are lights, 110 faces, 0.0M casts

Light: 0.0, Elapsed: 0:00
Light: 100.0, Elapsed: 0:00

lightdatasize: 0

Elapsed time : 0:00
__________________
Quakeone.com - Being exactly one-half good and one-half evil has advantages. When a portal opens to the antimatter universe, my opposite is just me with a goatee.

So while you guys all have to fight your anti-matter counterparts, me and my evil twin will be drinking a beer laughing at you guys ...
Unread 08-09-2006, 08:19 PM   #7 (permalink)
Gib Collector
USER INFO »
Posts: 3
+/-  Reputation: biffsnot is on a distinguished road
Join Date: Aug 2006
Currently: Offline
Ok, moved my darkplaces directory to c:\darkspaces and changed the WC3.3 configs to reflect that and now it compiles with textures. Thank you all for your help I dont know why it would give me a prob for such a simple thing lol. Must be due to the way WC3.3 has to be hacked to work with quake well.
Unread 08-09-2006, 08:22 PM   #8 (permalink)
Chthon
Baker's Avatar
USER INFO »
Posts: 9,975
+/-  Reputation: Baker has a spectacular aura aboutBaker has a spectacular aura aboutBaker has a spectacular aura about
Join Date: Nov 2005
Currently: Offline
I don't have multiple drives to test it on, but that makes a lot of sense.

All versions of Worldcraft including 1.6a and 3.3 use basically a batch file process to execute the compile, so this behavior isn't anything unique to use with the QuakeAdapter.

I'm glad it works now. :d
__________________
Quakeone.com - Being exactly one-half good and one-half evil has advantages. When a portal opens to the antimatter universe, my opposite is just me with a goatee.

So while you guys all have to fight your anti-matter counterparts, me and my evil twin will be drinking a beer laughing at you guys ...
Closed Thread

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to load textures for GTKRadiant? cyronix Servers and Coding 7 06-22-2010 03:01 AM
QuakeAdapter for Worldcraft 3.3 Baker Servers and Coding 4 09-07-2006 08:56 AM
Darkplaces runs better with textures foq Quake Central 36 07-12-2006 06:13 PM
Map Compile Trouble vegetous General Help 4 04-04-2006 08:07 AM
New Textures (Updated) woods Quake Central 0 01-31-2006 04:56 PM


All times are GMT -6. The time now is 09:02 AM.


eXTReMe Tracker