Site Navigation
QuakeOne News
» Latest News
» News Archives
» QuakeOne Movies

QuakeOne Help
» File Downloads
» Quake Help
» Quake Servers

QuakeOne Community
» Forums
» Chat *new*
» Poll Booth
» Memberlist
» Member Map

Site Info
» Community Rules
» Moderator List

» Buy Quake

Visit QuakeOne.com On Facebook!Visit QuakeOne
on Facebook

Log in
User Name:

Password:

Not a member yet?
Register Now!
Online Users: 392
14 members and 378 guests
303, Adam, Blood Vengeance, Bloodshot, Bloughsburgh, daeel, Focalor, hgdagon, lennox, MissBubbles, nahuel, talisa, Tea Monster
Most users ever online was 2,542, 06-04-2016 at 12:58 AM.
Go Back Home > Forums > Quake Mod Releases > Finished Works > Insomnia ProQuake 4.71 Engine + MOD Compilation [Sony PSP] Search Forums

Reply
LinkBack Thread Tools
Unread 06-22-2016, 12:30 PM   #21 (permalink)
Enforcer
Grzybiarz's Avatar
USER INFO »
Posts: 76
+/-  Reputation: Grzybiarz is on a distinguished road
Join Date: May 2016
Currently: Offline
Contact:  Send a message via Skype™ to Grzybiarz
All the functions that are needed for regular user are Difficulty Settings and adding/removing bots. You can add some other, but i think it will be a bit pointless because regular player wont know what these stands for, and advanced players, will just put it in console. You dont need to add any Difficulty option, because it is there already. Skill of the bots is being choosed in the settings of new multiplayer game. Easy stands for low AI and nightmare for the highest. I dont have any crashes while adding bots quickly. I just cant add any for about one second after i summon previous one. If you want to add this mod to your main game files, remember to switch off dynamic lights at default in config or autoexec.

Anwsering your question: add bot, add teambot and remove bot options works fine for me, without and crashes
Reply With Quote
Unread 06-22-2016, 02:22 PM   #22 (permalink)
Ogre
Dark_Duke's Avatar
USER INFO »
Posts: 120
+/-  Reputation: Dark_Duke is on a distinguished road
Join Date: Apr 2008
Currently: Offline
Ahh good point, didnt know that the difficulty option affected bot skill.

In general, any other options/features you'd like to see in the next official revision?
Reply With Quote
Unread 06-22-2016, 02:34 PM   #23 (permalink)
Enforcer
Grzybiarz's Avatar
USER INFO »
Posts: 76
+/-  Reputation: Grzybiarz is on a distinguished road
Join Date: May 2016
Currently: Offline
Contact:  Send a message via Skype™ to Grzybiarz
I think the option to disable crosshair in menu is something i would like to be added, and is not hard to make. I think. :p

Also, I would love if you put texture filter switch off option (pixeleted textures like in original quake for Dos), but i heard from kurok creator that you would need to change some things in code, so it is not something that is nessecary.

Last edited by Grzybiarz; 06-22-2016 at 02:44 PM..
Reply With Quote
Unread 06-23-2016, 01:20 AM   #24 (permalink)
Ogre
Dark_Duke's Avatar
USER INFO »
Posts: 120
+/-  Reputation: Dark_Duke is on a distinguished road
Join Date: Apr 2008
Currently: Offline
Unfortunately, I believe that MDave is right and the filter you are talking about is hardcoded into code for the Kurok engine. In fact, I tried doing a build of his "software" render, but it absolutely refuses to compile.
Reply With Quote
Unread 06-23-2016, 01:23 AM   #25 (permalink)
Enforcer
Grzybiarz's Avatar
USER INFO »
Posts: 76
+/-  Reputation: Grzybiarz is on a distinguished road
Join Date: May 2016
Currently: Offline
Contact:  Send a message via Skype™ to Grzybiarz
Ok. It is not that big problem for me. Thank you for checking that
Reply With Quote
Unread 06-23-2016, 01:28 AM   #26 (permalink)
Ogre
Dark_Duke's Avatar
USER INFO »
Posts: 120
+/-  Reputation: Dark_Duke is on a distinguished road
Join Date: Apr 2008
Currently: Offline
No problem man, I was curious myself!

Development Build Update for Testing: Revision 2.1

===CHANGELOG===
Bot Options under Multiplayer tab are now linked for FROGBOTS
Bot Options will autohide when not in FROGBOTS

Added Crosshair Enable/Disable Option under OPTIONS > SUBMENU MISC OPTIONS
Added Autoaim Enable/Disable Option under OPTIONS > SUBMENU MISC OPTIONS
DOWNLOAD: DEV Insomnia ProQuake 4.71 Revision 2.1
Reply With Quote
Unread 06-23-2016, 02:23 AM   #27 (permalink)
Enforcer
Grzybiarz's Avatar
USER INFO »
Posts: 76
+/-  Reputation: Grzybiarz is on a distinguished road
Join Date: May 2016
Currently: Offline
Contact:  Send a message via Skype™ to Grzybiarz
crosshair and autoaim options works perfectly, but bot options doesent show up even when playing frogbot mod.

When you switch on the Standby mode on your PSP and then switch it back to normal mode, bgmtype automatically changes to "none". I belive that happened also in regular proquake. I suggest you adding option to change music type, simmilar to that from jurajstyk version. It will solve the problem, as soon as another music start playing. Or you can just put "bgmtype cd" in autoexec that will solve the problem as well.

Last edited by Grzybiarz; 06-23-2016 at 11:37 AM..
Reply With Quote
Unread 06-23-2016, 11:37 AM   #28 (permalink)
Ogre
Dark_Duke's Avatar
USER INFO »
Posts: 120
+/-  Reputation: Dark_Duke is on a distinguished road
Join Date: Apr 2008
Currently: Offline
Originally Posted by Grzybiarz View Post
crosshair and autoaim options works perfectly, but bot options doesent show up even when playing frogbot mod.

When you switch on the Standby mode on your PSP and then switch it back to normal mode, bgmtype automatically changes to "none". I belive that happened also in regular proquake. I suggest you adding option to change music type, simmilar to that from jurajstyk version. It will solve the problem, as soon as you another music start playing. Or you can just put "bgmtype cd" in autoexec that will solve the problem as well.
Will look into adding option for setting bgmtype in menu! On similar note, is your frogbots folder called "frogbot", "frogbots", "FROGBOT" or "FROGBOTS"? Regardless, I'll be sure to make sure it applies to all of them
Reply With Quote
Unread 06-23-2016, 11:40 AM   #29 (permalink)
Enforcer
Grzybiarz's Avatar
USER INFO »
Posts: 76
+/-  Reputation: Grzybiarz is on a distinguished road
Join Date: May 2016
Currently: Offline
Contact:  Send a message via Skype™ to Grzybiarz
My frogbot folder is just called "frogbot".

There is a problem with moving using analog. When you are moving forward with analog, your strafe speed becomes very limited and it is almost like you cant strafe while using analog to move forward.

Also i just discovered that if you try to exit the game while in prompt menu, your PSP freeze.

Thank you very much for making this port better. You are awesome.

Last edited by Grzybiarz; 06-23-2016 at 01:40 PM..
Reply With Quote
Unread 06-23-2016, 02:59 PM   #30 (permalink)
Ogre
Dark_Duke's Avatar
USER INFO »
Posts: 120
+/-  Reputation: Dark_Duke is on a distinguished road
Join Date: Apr 2008
Currently: Offline
Ah! My frogbot folder was "frogbots" with an s at the end. I'll adjust it so that it only looks for either and make sure its not case-sensitive.

Interesting with the analog movement. Was this an issue in the other versions?

When you are leaving the prompt menu, are you hitting HOME > EXIT or are you using the Circle to quit button?
Reply With Quote
Reply

Bookmarks

Tags
baker, engine, proquake, psp, quake


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 05:45 PM.


eXTReMe Tracker