Site Navigation
QuakeOne News
» Latest News
» News Archives
» QuakeOne Movies

QuakeOne Help
» File Downloads
» Quake Help
» Quake Servers

QuakeOne Community
» Forums
» Chat *new*
» Poll Booth
» Memberlist
» Member Map

Site Info
» Community Rules
» Moderator List

» Buy Quake

Visit QuakeOne.com On Facebook!Visit QuakeOne
on Facebook

Log in
User Name:

Password:

Not a member yet?
Register Now!
Online Users: 397
13 members and 384 guests
303, Adam, Blood Vengeance, Bloodshot, Bloughsburgh, daeel, Focalor, hgdagon, lennox, nahuel, QwertyKb, Tea Monster
Most users ever online was 2,542, 06-04-2016 at 12:58 AM.
Go Back Home > Forums > Quake Mod Releases > Finished Works > Small Mod compilation Search Forums

Reply
LinkBack Thread Tools
Unread 12-22-2010, 03:28 AM   #21 (permalink)
Chthon
Seven's Avatar
USER INFO »
Posts: 3,126
+/-  Reputation: Seven is a jewel in the roughSeven is a jewel in the roughSeven is a jewel in the rough
Join Date: Oct 2007
Currently: Offline
Hello ooppee,

yes, they do disappear after 30 seconds.
They do this silently, without waking up nearby monsters
Reply With Quote
Unread 03-08-2011, 08:15 PM   #22 (permalink)
Chthon
gdiddy62's Avatar
USER INFO »
Posts: 1,517
+/-  Reputation: gdiddy62 is on a distinguished road
Join Date: Jan 2011
Currently: Offline
Seven,
I'm afraid I'm having issues with the Rogue mod compilation. The Quake and Hipnotic compilations work spot on with no issues on any of the mods.
With the Rogue compilation, the start map has the old flame and then I have no flame at all on R1M1. I'm using your suggested Darkplaces build : dark_places_engineautobuild_20110203. The only other pk3 file in the Rogue folder is OoPpEe's weapons, which is also a pk3 present in the Hipnotic folder which works fine. I've tried removing the weapons pk3 to see if that might do it, but no luck. Any ideas why Rogue is the only one not working for me?
Great mods by the way!
Sorry for the bother.
Reply With Quote
Unread 03-08-2011, 09:42 PM   #23 (permalink)
Chthon
gdiddy62's Avatar
USER INFO »
Posts: 1,517
+/-  Reputation: gdiddy62 is on a distinguished road
Join Date: Jan 2011
Currently: Offline
Well, I seem to have solved the problem by extracting the contents of the pk3 file and placing them in the Rogue folder individually. I did the following:
Created an id1 folder within the Rogue folder and placed sounds, qc, and prog folders into this. I then placed the progs dat and progs.ino into the main Rogue folder and now have all of the mods working. Bizarre when the pk3 file works perfectly in the original Quake and Hipnotic??
Reply With Quote
Unread 03-08-2011, 10:22 PM   #24 (permalink)
Formerly OoPpEe
LambentHammerBurst's Avatar
USER INFO »
Posts: 1,668
+/-  Reputation: LambentHammerBurst is on a distinguished road
Join Date: Oct 2010
Currently: Offline
Contact:  Send a message via MSN to LambentHammerBurst
Originally Posted by gdiddy62 View Post
Created an id1 folder within the Rogue folder and placed sounds, qc, and prog folders into this.
Why would you do this?
The ...\quake\rogue\id1
would be completely ignored
it'd load the content from:
...\quake\rogue\progs
...\quake\rogue\sounds
fine but nothing within
...\quake\rogue\id1\


The likely issue was you had a progs.dat already in the rogue folder not in a pk3 which would get loaded over it. How Darkplaces appears to load in order is:
.pak
.pk3
/folders

so if I have my Moo version Grunt in a pk3 but then another Grunt model in my folder. It will load the one in the folder over the pk3. Could of easily been the same issue - a different progs.dat was present in the folder.
Reply With Quote
Unread 03-09-2011, 06:36 AM   #25 (permalink)
Chthon
gdiddy62's Avatar
USER INFO »
Posts: 1,517
+/-  Reputation: gdiddy62 is on a distinguished road
Join Date: Jan 2011
Currently: Offline
OoPpEe,
There was a progs.dat file in the main Rogue folder which I replaced with the one from Seven's pk3. Thanks for responding so that I now know what the issue was. I was just stabbing for a solution due to my ignorance. I'm learning though! So if I had just deleted the other progs.dat that would have been enough right?
Regards
Jeff
Reply With Quote
Unread 03-09-2011, 12:34 PM   #26 (permalink)
Drole
USER INFO »
Posts: 186
+/-  Reputation: jakub1 is on a distinguished road
Join Date: Jan 2010
Currently: Offline
hi seven,
-
i've tried this small mod pack of yours and i have two comments:

1. fixed nail position, footsteps sounds and the nails in the walls ... all this stuff is nice
2. this mod affects wizard's and hellknight's spike model as well ... and that's bad.

the problem was that after a short battle with a bunch of wizards i found myself in a room whose walls were covered with great number of wizard's spikes stuck in these walls. each of the wizard's spikes was a source of light. as you can imagine - dp framerate went to hell. same goes for hellknight's spike model.
-
has anyone encountered this problem too?
Reply With Quote
Unread 03-09-2011, 01:58 PM   #28 (permalink)
Chthon
Seven's Avatar
USER INFO »
Posts: 3,126
+/-  Reputation: Seven is a jewel in the roughSeven is a jewel in the roughSeven is a jewel in the rough
Join Date: Oct 2007
Currently: Offline
@ gdiddy62

If you have a progs.dat in your rogue folder, then it is not original/correct.
There is no progs.dat in ANY mission pack or Quake folder.
Quakeīs progs.datīs are always hidden in the first .pak file.
My mod will always override this progs.dat and the modīs progs.dat will be used.
So simply dropping the modīs .pk3 into your folder is enough.
I dont know why you had a progs.dat in your rogue... strange.
But you already found the solution and I am happy


@ jakub1

EDITED
I just simulated what you said, and first I thought that you are right.
But the reason for the FPS drop is not the nail-stick-in-the-wall mod.
It is the "effectinfo.txt"
I used my "older" mod without the nail-stick-in-the-wall addon and the behaviour was similar.
Then I deleted the effectinfo.txt and viola: no FPS drop.
So the decals from monster shots hit the walls is causing it.

Still, the reason why I never noticed the FPS impact is, that the monsters normally die quite quick, without leaving too many wall decals.
But I can imagine, that when you play a custom map with many hellknights or scrags in one spot, you will notice the impact.

So the question can and must be answered by everybody individually:
What do you prefer ? The effect or an FPS impact from time to time ?
According to your answer you can either delete the decal lines in the effectinfo.txt or use it completely.

Thank you for mentioning it.

Kind regards,
Seven

Last edited by Seven; 03-09-2011 at 02:32 PM..
Reply With Quote
Unread 03-09-2011, 09:31 PM   #29 (permalink)
Chthon
gdiddy62's Avatar
USER INFO »
Posts: 1,517
+/-  Reputation: gdiddy62 is on a distinguished road
Join Date: Jan 2011
Currently: Offline
OoPpEe, Seven,
Thank both of you for taking the time to answer my question. I deleted the id1 folder I created since it was not needed and since I had replaced the prog.dat file with seven's I deleted it as well and am just using the pk3 file.. all is well! I also am experiencing the Wizard's magic attack sticking like nails. I personally love the effect.info effects so I'll live with it and take the fps hit.
regards,
Jeff
Reply With Quote
Unread 03-11-2011, 12:52 PM   #30 (permalink)
Chthon
Seven's Avatar
USER INFO »
Posts: 3,126
+/-  Reputation: Seven is a jewel in the roughSeven is a jewel in the roughSeven is a jewel in the rough
Join Date: Oct 2007
Currently: Offline
UPDATE 20110311

jakub1 discovered a small but important issue:
The Nail-Stick-In-Walls mod makes also the wizards and Hellknights spike stick in walls.
This alone is not a problem, but in combination with a custom "effectinfo.txt" (like this one),
which spawns a light around the wizards and hellknights spikes,
your FPS will drop real quickly during a fight. And the walls look like a christmas tree

So I draw the consequences and modified the Nail-Stick-In-Walls mod:
I removed the Nailgun-nails from it and only left the supernailgun-nails in it !
Reason: The Wizards and Hellknights spike follow exactly the nailgun-nails code.
The supernailgun-nails dont impact anything, so I left them untouched.

This leads to new versions: V.2.5
With V.2.5 you will have no more FPS drop caused from the monsters spike lights.
On top of that, the walls will not look like christmas trees.
They look now as they should (the beautiful effectinfo.txtīs effects are back again) !


On top of that I included the "kill all monsters" cheat in all versions.
Read more about it here.
Now you can kill all monsters instantly with the "impulse 205" genocide command/cheat.


Please download the newest Versions (found in post #1)


Kind regards,
Seven
Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 2 (0 members and 2 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 05:30 PM.


eXTReMe Tracker