Announcement

Collapse
No announcement yet.

I can't compile Sevens modified source qc

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • ezwa
    replied
    Originally posted by Seven View Post
    Hello quake one,

    You seem to be very angry about it. Judging by the icon you used.
    Your question has already been answered at func_msgboard.
    So everything should be clear by now.



    Hello Monty,

    Thank you very much for jumping in and help.
    Your assumptions are correct (as always).
    Using the included compiler, or using new source with new compiler, or deleting unwanted chars will lead to success.

    Best wishes,
    Seven
    I found "fteqccgui2770-win32.zip" in an index of quaddicted.com and the fteqcc.exe that can be found in this zip file can compile successfully the "seven modified source qc" of the epsilon build 2016 without error if optimization is set to O0.

    But I downloaded from dropbox smc 5.50, which already comes with a fteqcc.exe that can compile the source, and smc 5.50 is much better than smc 3.80 that comes with that epsilon build 2016, because it supports new enemies, artificial intelligence and much more!

    Leave a comment:


  • Seven
    replied
    Hello quake one,

    You seem to be very angry about it. Judging by the icon you used.
    Your question has already been answered at func_msgboard.
    So everything should be clear by now.



    Hello Monty,

    Thank you very much for jumping in and help.
    Your assumptions are correct (as always).
    Using the included compiler, or using new source with new compiler, or deleting unwanted chars will lead to success.

    Best wishes,
    Seven

    Leave a comment:


  • Mr.Burns
    replied
    Hi "Quake One"
    I could be wrong here, but as I understand it there are 2 seperate entities here
    1. The superb SMC mod which was created by Seven, and
    2. The "quake_epsilon_v2" mod which I understand is something published by some other individual taking Seven's mod, "modifying" it and renaming it as their own work.
    It sounds as though you are using the 2nd entity so have you approached the author?

    The error message could suggest something as simple as a collation/charset issue when editing/saving or a slight corruption in the ogre.qc file. Perhaps try the recompile with a version of the Orge.qc from seven's original version, the last "known good" as it were, especially as we have no idea what changes have been applied to the code base in the Epsilon mod.

    Hope this may help in some way

    Kind regards

    Monty
    Last edited by Mr.Burns; 09-13-2021, 01:50 AM.

    Leave a comment:


  • ezwa
    started a topic I can't compile Sevens modified source qc

    I can't compile Sevens modified source qc

    Recently I downloaded the "quake_epsilon_v2_54_18-12-2016.zip" file from the "moddb.com" website, extracted everything and then I tried, with all the fteqccgui64.exe, fteqccgui.exe, fteqcc64.exe and fteqcc.exe, to compile the "progs.src" file inside the "Sevens modified source qc" folder/directory that is inside the "00_Quake-Small-Mod-Compilation-V3.80--Seven-20120409" folder/directory that is inside the "readmes" folder/directory that is inside the "id1" folder/directory.

    but compilation fails with the repeating error:

    ogre.qc:986: error: Invalid UTF-8 code sequence at end of line. Lead byte was 0xa0

    Both I don't know why compilation fails with this repeating error and I don't know how to get rid of this error.

    In fact I don't know at all how this source code was compiled in the past.

    Please help me!

    I do want to modify epsilon build to my likings to make this game, Quake, even more fun than what it is now!
Working...
X