No announcement yet.

Issue with Soul of Evil. Not sure if it's a port issue or what.

  • Filter
  • Time
  • Show
Clear All
new posts

  • Issue with Soul of Evil. Not sure if it's a port issue or what.

    I got as far as The Morbid Manse on the second episode Soul of Evil before I came to a point in the game where I cannot progress any further. After shooting the three altars and collecting the Silver Key, I am supposed to pass through three doors according to the on-screen text. I manage to pass through the first door where I'm in a library fighting Scrags and cultists/wizards that shoot fireballs and Scrag slime at me. I believe I am supposed to kill all of these cultists/wizards before I progress to the next door. However, on both Fitzquake 0.85 and the latest version of DarkPlaces I am left with one cultist/wizard left to kill yet it is nowhere to be found. I've tried restarting the level from scratch on a number of occasions, I tried noclipping to see if I could spot the issue, I tried rocketjumping onto a number of different places, and a number of other things to fix this or find out what I am supposed to do and I am completely stumped. It leaves me stuck in the library, unable to go back through the first door and I'm unable to pass through the second door.

    I'm not sure if I'm doing something wrong or what, but I was hoping someone could tell me what's going on, whether I forgot to do something (like one point in Abyss of Pandemonium where if you forget to get the silver key in one of the levels you end up stuck where you get ambushed by Shamblers and Vores), if it's a map bug, if it's a bug in the two engines I tried, or what. Any and all help, suggestions, and such would be appreciated very much.

  • #2
    Hi, Tronyn here. This is probably a mistake of mine - what skill level are you on?
    Did you kill a dragon monster? One should appear. Once you kill these monsters, a pathway should open in the clock room, to go on the walkways above the library and continue to get the rocket launcher. If things don't work at all, just go back into the room (checkerboard floor) from which you can see the clock, and noclip through the door. Sorry about this.


    • #3
      Howdy Tronyn,

      I was playing on Nightmare difficulty on both FitzQuake 0.85 and the latest version of DarkPlaces. I don't recall encountering a dragon monster at all in The Morbid Manse. I'll give what you told me a go later today to see if that works. Thanks. (:


      • #4
        I decided to take a look, since I completed SOE some time ago. After a quick running through with godmode, I ran into this same issue. I remember having the same difficulty as you have back then, so I had to noclip into the little room into the middle to press the button. I use nightmare difficulty on Joequake-gl.