Announcement

Collapse
No announcement yet.

Vanilla Quake Fixes

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Seven
    replied
    Hello Alexandra,

    First of all, putting a start.ent file into an id1 mod is not the best idea.
    As you already said, lots of fan made episodes also use a start map.

    You already learned how to ignore .ent files.
    But what if your mod also uses .ent files ?
    Then you need to create a matching start.ent file to the start map of your mod.
    And you can remove the sv_entpatch line again.
    Here are instructions of how to proceed.



    By the way,
    Did you know, by starting regular Quake, you are using: -game id1 ?
    With that knowledge, you can now setup your Quake to do, as you explained:
    Use id1 replacements without the necessity to have it in other mods as well.
    Using multiple -game arguments is possible.

    Leaving your id1 as clean as possible is always a good idea.

    Enjoy your Quake.

    Best wishes,
    Seven

    Leave a comment:


  • Alexandra
    replied
    @talisa
    Thanks for the tip, will add to autoexec. That will help with the ent issue for sure.

    I do worry about other /id1 elements perhaps conflicting with mods. Sounds like there's no way to exclude an /id1 .pak entirely without just breaking its filename extension, huh (the .bat file rename trick).

    Leave a comment:


  • NightFright
    replied
    Revision 6 has been released. Download link in OP.

    Highlights:
    - Nextthink fixes are back without breaking HIP1M4
    - Swimming up with +jump is now (almost) as fast as +forward and looking up
    - Autoaiming no longer reset after loading new map

    As for the ent fixes, I have made a special quakespasm.pak replacement for Quakespasm only, containing ent fixes for Quake vanilla and Enhanced which will ONLY load with maps from those two editions. Even the wrong music tracks in E4Mx maps from Enhanced have been corrected. However, I cannot put these in a project like this since it works with checksums, a feature currently only supported by latest (!) Quakespasm, Quakespasm-Spiked and vkQuake builds. I have presented my fixes to the Quakespasm team already for review. It's possible they will eventually implement them into the official release so you would have map fixes + z-fighting issues resolved in ID1/SoA/DoE.
    Last edited by NightFright; 09-13-2021, 10:47 AM.

    Leave a comment:


  • talisa
    replied
    Alexandra

    simply add an autoexec.cfg to the folder of the mod with the line "sv_entpatch 0" in it (without implication marks),
    which will tell darkplaces to NOT load any ent-files and solve your issue

    .

    if an autoexec.cfg doesnt exist yet, you can easily make an autoexec.cfg yourself using notepad or such,
    as a .cfg file is simply a text-file, so just make a text-file and manually rename the file-extension to .cfg

    Leave a comment:


  • Alexandra
    replied
    Thank you for this, NightFright. I love "vanilla+" mods, and am particularly pleased to have an easy way to pull in the new HQ sounds.

    I'm returning to Quake after a long time away and have a somewhat basic question. I noticed that when I put this mod in /id1, it will cause problems when I run mods from other folders, such as Abyss of Pandemonium or DOPA. Each of those mods' start maps became severely screwed up, I assume because it was pulling start.ent from your vanilla mod in /id1. My question, is there any way to keep your mod installed in /id1 and still be able to load different gamedirs without it interfering?

    (If not, I'll probably just create batch files to "switch on" and "switch off" any /id1 mods that cause issues for other gamedirs.)

    Leave a comment:


  • Dopefish
    replied
    Coolers. It works for both of them now, and the HIP1M4 fix is still there. Thanks for accommodating my request!

    EDIT:
    Checked jumping/shooting for respawning while I was at it, and it seems to be working aswell. That was another minor issue we had in coop, but wasn't aware it was from these changes, so it's nice to see it fixed aswell ^^
    Last edited by Dopefish; 09-06-2021, 01:06 PM.

    Leave a comment:


  • NightFright
    replied
    Indeed. Forgot to update my working folder. Link above is fixed now.

    Leave a comment:


  • Dopefish
    replied
    Think you uploaded the previous version of the pak files (last modified 2021-09-04 13:12).

    Leave a comment:


  • NightFright
    replied
    Download this and see if the following is fixed in SoA and DoE:
    - Sliding/not-jumping on monsters/boxes/players fix
    - Shooting/jumping when respawning fix

    Test build (13.5 MB)

    I hope no further adjustments of the game code will be needed since it is really not a pleasant task.
    Last edited by NightFright; 09-06-2021, 12:44 PM.

    Leave a comment:


  • Dopefish
    replied
    Another minor inconsistency between id1 and hipnotic/rogue, is the behavior for when standing ontop of entities (enemies/other players). In id1 you don't slide around and are able to jump, which allows for things such as boosting in coop and generally feels nice. Hipnotic/rogue behaves the same as unpatched Quake, where you simply slide around ontop of the other characters.

    Would be nice if hipnotic/rogue got this update aswell ^^

    Leave a comment:


  • Dopefish
    replied
    Did a speedrun of episode 1 with the second fix, and didn't notice anything off. My sv_aim settings didn't get overridden atleast

    Leave a comment:


  • NightFright
    replied
    No no, I saw the first fix was working. I just wanted to purge all related code in world.qc (which has more sv_aim resets in it) to see if it has any negative impact.

    Leave a comment:


  • Dopefish
    replied
    Originally posted by NightFright View Post
    OK, one more. This time I totally deactivated the entire autoaim code block in world.qc, not just one line.
    Sorry, I was replying to things a bit out of order. The previous fix was sufficient to fix the issues, so there's no need for the second attempt at it

    Leave a comment:


  • NightFright
    replied
    OK, one more. This time I totally deactivated the entire autoaim code block in world.qc, not just one line.
    Attached Files

    Leave a comment:


  • Dopefish
    replied
    Yes, please, it would be much appreciated, and there might be others coming across this in the future that would be happy for the fix <3

    EDIT:
    The fix works perfectly, thank you!

    Originally posted by NightFright View Post
    Does this happen only in ID1 (original campaigns) or the addons as well?
    And yes, now when testing further, it only happened with ID1

    Leave a comment:

Working...
X