So, as the title suggests I'm having some issues getting Quake running at a stable framerate with DOSBox, I do need to let you know that I have successfully alleviated the problem in Quake, Scourge of Armagon, and Dissolution of Eternity, by appending 'vid_wait 1' (this was suggested in a thread on the GOG forums) to my autoexec.cfg file in the id1 folder.

I am, however, still having some issues with Abyss of Pandemonium; it seems to ignore 'vid_wait 1', intermittently speeding out of control to the point where it's almost impossible to play. I've tried going with the lowest config settings I can, even going so far as to set the CPU mode in DOSBox to that of a 33 MHz 80386, which it shouldn't even be able to run on, but it still experiences what I've termed 'catastrophic speed-ups'.

If any of you have experienced this and know of any possible solutions, the help would most greatly appreciated.