Announcement

Collapse
No announcement yet.

QRack: Couldn't set fullscreen DIB mode

Collapse
This is a sticky topic.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • QRack: Couldn't set fullscreen DIB mode

    Having a problem w/ Qrack, it says when i try to run it...
    Quake Error: Couldn't set fullscreen DIB mode.

    I usually use WQPro, and Joequake runs just fine. Any ideas?

  • #2
    Heard about this before do you have an ATI card? DIB is device independant bitmap, tried rebooting?

    also make sure your qrack command line looks like the example on this page http://www.quakeone.com/qrack/index.php?page=guide

    Comment


    • #3
      That error appears every now and then with an ATI it seems. In my case sometimes quitting certain programs help (eg winamp), no idea why. Also closing all windows or running some other engine first might help.
      Quake 1 Singleplayer Maps and Mods

      Comment


      • #4
        Your probably either have an old version or qrack, (get new one here: http://www.quakeone.com/qrack), or you are trying to set -refreshrate on the command line higher than your monitor supports, ususually only 60hz on a flatpanel.
        uakene.com

        Comment


        • #5
          If all else fails use -refreshrate 60 in your commandline shortcut
          www.quakeone.com/qrack | www.quakeone.com/cax| http://en.twitch.tv/sputnikutah

          Comment


          • #6
            This question has surfaced in the forum 3 times, so it may come up even more frequently. Might be good to put the answer on the Qrack page somewhere.
            Quakeone.com - Being exactly one-half good and one-half evil has advantages. When a portal opens to the antimatter universe, my opposite is just me with a goatee.

            So while you guys all have to fight your anti-matter counterparts, me and my evil twin will be drinking a beer laughing at you guys ...

            Comment


            • #7
              Bumped this thread for Frenzy
              Quakeone.com - Being exactly one-half good and one-half evil has advantages. When a portal opens to the antimatter universe, my opposite is just me with a goatee.

              So while you guys all have to fight your anti-matter counterparts, me and my evil twin will be drinking a beer laughing at you guys ...

              Comment


              • #8
                I was just about to make a new post about this but I see it's already been taken care of. I'll do what you guys suggested to fix this problem.

                Comment


                • #9
                  I'll post the fix in the Qrack thread this evening plus a few other goodies for Rook.

                  It is easily fixed in the engine by removing 3 lines of code.
                  Quakeone.com - Being exactly one-half good and one-half evil has advantages. When a portal opens to the antimatter universe, my opposite is just me with a goatee.

                  So while you guys all have to fight your anti-matter counterparts, me and my evil twin will be drinking a beer laughing at you guys ...

                  Comment


                  • #10
                    hmm i thought it was fixed.
                    hdc = GetDC(NULL);
                    modelist[MODE_FULLSCREEN_DEFAULT].refreshrate = GetDeviceCaps(hdc,VREFRESH);
                    modelist[MODE_FULLSCREEN_DEFAULT].bpp = GetDeviceCaps(hdc, BITSPIXEL);
                    ReleaseDC(NULL, hdc);
                    This should set startup settings to desktop unless its changed in the cfg.... hmm :S
                    www.quakeone.com/qrack | www.quakeone.com/cax| http://en.twitch.tv/sputnikutah

                    Comment


                    • #11
                      Okay, better yet...

                      for (i=1, vid_default=0 ; i<nummodes ; i++)
                      {
                      if ((modelist[i].width == width) && (modelist[i].bpp == bpp) && (modelist[i].refreshrate == refreshrate))
                      {
                      vid_default = i;
                      done = 1;
                      break;
                      }
                      }
                      I had to check the refreshrate for each mode.

                      You probably noticed even if u used -refreshrate in the commandline it would startup using 640x480 @59hz... now instead it will set the mode+refreshrate properly and no more double "VID_SetMode" ....

                      EDIT:
                      Okay this works perfectly for me on both my lcd and CRT, if not specified -width/-height etc it grabs the settings from the desktop. And Qrack starts up much faster now will post an updated version tonight.
                      Last edited by R00k; 02-19-2008, 04:07 PM.
                      www.quakeone.com/qrack | www.quakeone.com/cax| http://en.twitch.tv/sputnikutah

                      Comment


                      • #12
                        hmm nice.. proquake needs that too

                        Comment


                        • #13
                          Originally posted by =peg= View Post
                          hmm nice.. proquake needs that too
                          Explain a little more so I understand what you mean.

                          And Qrack starts up much faster now
                          That's blazing fast. I was shocked.

                          I'm jealous!!! Seriously!!!

                          I need your source code.
                          Quakeone.com - Being exactly one-half good and one-half evil has advantages. When a portal opens to the antimatter universe, my opposite is just me with a goatee.

                          So while you guys all have to fight your anti-matter counterparts, me and my evil twin will be drinking a beer laughing at you guys ...

                          Comment


                          • #14
                            well i meant that proquake just grabs your desktop settings and uses that by default (unless specified otherwise in config.cfg or commandline) so it does not need to initialize twice.. => starts up faster

                            Comment


                            • #15
                              ProQuake initializes twice because it is using the FitzQuake style startup routine. It is doing the ProQuake default resolution of 640 x 480 and then reading the config and changing the video mode (a 2nd video initialization).

                              Rook apparently is using a vastly superior method that reads the settings before video initialization. (It's probably reading the config earlier and then executing it later ... my guess).

                              I think if I were to change the default video mode in ProQuake, it would look through the list and find the fastest resolution that matches the aspect ratio for higher FPS.

                              For example, on a 4:3 display like both my CRTs, I think 640 x 480 is the ideal instead of 1280x960 because the FPS is much higher. On my widescreen laptop, I'd have it use 640x400 instead of whatever the super high res default is.

                              I've noticed that performance is significantly degraded by those multi-megapixel wide screen resolutions. I get about 60 FPS on my laptop with 1440 x 900, but get 200 FPS with a more reasonable resolution.
                              Quakeone.com - Being exactly one-half good and one-half evil has advantages. When a portal opens to the antimatter universe, my opposite is just me with a goatee.

                              So while you guys all have to fight your anti-matter counterparts, me and my evil twin will be drinking a beer laughing at you guys ...

                              Comment

                              Working...
                              X