Announcement

Collapse
No announcement yet.

Small Mod compilation

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    kingennio,

    this is a modification of QC files.
    It is totally different to "gimmicks pack´s" like High-Res-Textures or DP-Pretty-Water.
    You cannot simply delete something. You have to change the code.
    I included the source code for my pack in the download.
    You can compare it with the source code for Quake 1.06 and will see the difference.

    So what you want to do is, remove my code-modifications.
    Its simple, if you use a text-comparing-program like winmerge or Beyond Compare.

    You must understand QC to do that of course !

    After you modified the qc files, you must compile them to create the new progs.dat.
    Use the included FTE compiler for this job. There is a version with GUI included as well.

    Kind Regards,
    Seven

    PS: 3 years ago I uploaded the single modifications here:
    - NailgunNailPosition Only
    - NewFire Only
    Last edited by Seven; 11-11-2010, 08:52 AM.

    Comment


    • #17
      Thanks Seven. Indeed it looks too complicated. I'll stick to the 4 mods together then...
      BTW, I sent you a PM with the link to the normal maps.
      Regards

      Comment


      • #18
        UPDATE 20101201

        I extended this pack once again by adding:
        - Nails stick in walls (Special Thanks to Spinvis for this great mod)
        - Plasma Gun bug fix in Mission pack 2 for DarkPlaces (Special Thanks to OoPpEe for his workaround)
        - Tweaked the Lava Nailgun Nail-position a bit


        Nails stick in Walls mod:
        This mod makes nails stick in walls. (see screenshots)
        Spinvis used the tutorial from Pastor as base,
        but tuned it pretty much (adjusted the visible nail-lenght and so on).

        ,


        Plasma Gun bug fix in Mission pack 2 for DarkPlaces:
        There is a bug in DarkPlaces (until today 20101201) which prevented the
        plasma gun shot from flying forward. Instead it was stuck in the air.
        OoPpEe manged to circumvent this bug by editing the MULT_WPN.QC.
        Maybe in the future (when LordHavoc killed the bug) OoPpEe´s fix is no longer necessary
        and can be removed (it is edited in the .QC file).


        Updated Download Links in 1st post.

        Kind Regards,
        Seven
        Last edited by Seven; 12-01-2010, 02:53 PM.

        Comment


        • #19
          Correction 20101221

          I noticed, that the Lava Nails didnt stick in the walls.
          Regular Nails did work fine.

          I checked the QC files and found that I forgot to update "LAVA_WPN.QC".

          This is fixed now. Now all things work properly.

          Updated Download Link (Rogue) in 1st post.

          Kind Regards,
          Seven

          Comment


          • #20
            Have yet to try this. One question I do have to ask. Do the nails stay in there forever or will they disappear after awhile?
            I think I may borrow the nail code you got and after 30 secs - 1 minute they will "explode" (zero damage) into just small little metal gibs (which disappear quickly)

            Comment


            • #21
              Hello ooppee,

              yes, they do disappear after 30 seconds.
              They do this silently, without waking up nearby monsters

              Comment


              • #22
                Seven,
                I'm afraid I'm having issues with the Rogue mod compilation. The Quake and Hipnotic compilations work spot on with no issues on any of the mods.
                With the Rogue compilation, the start map has the old flame and then I have no flame at all on R1M1. I'm using your suggested Darkplaces build : dark_places_engineautobuild_20110203. The only other pk3 file in the Rogue folder is OoPpEe's weapons, which is also a pk3 present in the Hipnotic folder which works fine. I've tried removing the weapons pk3 to see if that might do it, but no luck. Any ideas why Rogue is the only one not working for me?
                Great mods by the way!
                Sorry for the bother.

                Comment


                • #23
                  Well, I seem to have solved the problem by extracting the contents of the pk3 file and placing them in the Rogue folder individually. I did the following:
                  Created an id1 folder within the Rogue folder and placed sounds, qc, and prog folders into this. I then placed the progs dat and progs.ino into the main Rogue folder and now have all of the mods working. Bizarre when the pk3 file works perfectly in the original Quake and Hipnotic??

                  Comment


                  • #24
                    Originally posted by gdiddy62 View Post
                    Created an id1 folder within the Rogue folder and placed sounds, qc, and prog folders into this.
                    Why would you do this?
                    The ...\quake\rogue\id1
                    would be completely ignored
                    it'd load the content from:
                    ...\quake\rogue\progs
                    ...\quake\rogue\sounds
                    fine but nothing within
                    ...\quake\rogue\id1\


                    The likely issue was you had a progs.dat already in the rogue folder not in a pk3 which would get loaded over it. How Darkplaces appears to load in order is:
                    .pak
                    .pk3
                    /folders

                    so if I have my Moo version Grunt in a pk3 but then another Grunt model in my folder. It will load the one in the folder over the pk3. Could of easily been the same issue - a different progs.dat was present in the folder.

                    Comment


                    • #25
                      OoPpEe,
                      There was a progs.dat file in the main Rogue folder which I replaced with the one from Seven's pk3. Thanks for responding so that I now know what the issue was. I was just stabbing for a solution due to my ignorance. I'm learning though! So if I had just deleted the other progs.dat that would have been enough right?
                      Regards
                      Jeff

                      Comment


                      • #26
                        hi seven,
                        -
                        i've tried this small mod pack of yours and i have two comments:

                        1. fixed nail position, footsteps sounds and the nails in the walls ... all this stuff is nice
                        2. this mod affects wizard's and hellknight's spike model as well ... and that's bad.

                        the problem was that after a short battle with a bunch of wizards i found myself in a room whose walls were covered with great number of wizard's spikes stuck in these walls. each of the wizard's spikes was a source of light. as you can imagine - dp framerate went to hell. same goes for hellknight's spike model.
                        -
                        has anyone encountered this problem too?

                        Comment


                        • #27
                          @gdiddy - yep if you would of just deleted the progs.dat it should of fixed it. Might not, I always leave progs.dat outside of files as I don't think the games code file should be compressed.

                          Comment


                          • #28
                            @ gdiddy62

                            If you have a progs.dat in your rogue folder, then it is not original/correct.
                            There is no progs.dat in ANY mission pack or Quake folder.
                            Quake´s progs.dat´s are always hidden in the first .pak file.
                            My mod will always override this progs.dat and the mod´s progs.dat will be used.
                            So simply dropping the mod´s .pk3 into your folder is enough.
                            I dont know why you had a progs.dat in your rogue... strange.
                            But you already found the solution and I am happy


                            @ jakub1

                            EDITED
                            I just simulated what you said, and first I thought that you are right.
                            But the reason for the FPS drop is not the nail-stick-in-the-wall mod.
                            It is the "effectinfo.txt"
                            I used my "older" mod without the nail-stick-in-the-wall addon and the behaviour was similar.
                            Then I deleted the effectinfo.txt and viola: no FPS drop.
                            So the decals from monster shots hit the walls is causing it.

                            Still, the reason why I never noticed the FPS impact is, that the monsters normally die quite quick, without leaving too many wall decals.
                            But I can imagine, that when you play a custom map with many hellknights or scrags in one spot, you will notice the impact.

                            So the question can and must be answered by everybody individually:
                            What do you prefer ? The effect or an FPS impact from time to time ?
                            According to your answer you can either delete the decal lines in the effectinfo.txt or use it completely.

                            Thank you for mentioning it.

                            Kind regards,
                            Seven
                            Last edited by Seven; 03-09-2011, 01:32 PM.

                            Comment


                            • #29
                              OoPpEe, Seven,
                              Thank both of you for taking the time to answer my question. I deleted the id1 folder I created since it was not needed and since I had replaced the prog.dat file with seven's I deleted it as well and am just using the pk3 file.. all is well! I also am experiencing the Wizard's magic attack sticking like nails. I personally love the effect.info effects so I'll live with it and take the fps hit.
                              regards,
                              Jeff

                              Comment


                              • #30
                                UPDATE 20110311

                                jakub1 discovered a small but important issue:
                                The Nail-Stick-In-Walls mod makes also the wizards and Hellknights spike stick in walls.
                                This alone is not a problem, but in combination with a custom "effectinfo.txt" (like this one),
                                which spawns a light around the wizards and hellknights spikes,
                                your FPS will drop real quickly during a fight. And the walls look like a christmas tree

                                So I draw the consequences and modified the Nail-Stick-In-Walls mod:
                                I removed the Nailgun-nails from it and only left the supernailgun-nails in it !
                                Reason: The Wizards and Hellknights spike follow exactly the nailgun-nails code.
                                The supernailgun-nails dont impact anything, so I left them untouched.

                                This leads to new versions: V.2.5
                                With V.2.5 you will have no more FPS drop caused from the monsters spike lights.
                                On top of that, the walls will not look like christmas trees.
                                They look now as they should (the beautiful effectinfo.txt´s effects are back again) !


                                On top of that I included the "kill all monsters" cheat in all versions.
                                Read more about it here.
                                Now you can kill all monsters instantly with the "impulse 205" genocide command/cheat.


                                Please download the newest Versions (found in post #1)


                                Kind regards,
                                Seven

                                Comment

                                Working...
                                X